CentOS를 사용했을 때에는 이러한 error가 발생하지 않았으나, Ubuntu에서 컴파일 하니 이런 error가 발생하였다. 이 때에는 #include <climits> 를 포함해주면 된다.